Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 02, 2025 - 09:00 EST
Scheduled
On Sunday, November 2, 2025, the Coverity on Polaris SaaS production systems will be upgraded to version 2025.9.0 during a scheduled maintenance window of 9am to 3pm Eastern Time.
What’s new? - Support for Coverity version 2025.9.0 with the following updates: - Support for Python 3.13. - Support for Kotlin 2.1.10. - Support for LLVM 19.1.0. - New and updated checkers. - Note: AIX support is delayed to Coverity 2025.12.0. - Support for Secure Code Warrior with links to training in the issue details page of the UI. - New CLI arguments for Detekt: detekt-max-mem (local analysis) and disable-detekt (central and local analysis). - Updates to reporting platform APIs impacting Coverity on-prem report capabilities.
For more details about the release, see the announcement published in the Black Duck [community portal].
Posted Oct 28, 2025 - 03:38 EDT
This scheduled maintenance affected: Reporting Services, Rest Services, UI Services, SCAN Services, and Integration Services.